Регистрация
Вход через соцсети
Восстановление пароля

Под IE7 не работает визуальный редактор

Новый топик
18.03.2007, 19:33
Ответить | Цитировать
Гость
Гость

Под IE7 не работает визуальный редактор. Пишет, что для работы необходим ИЕ 5.5 и выше. Есть ли какие-нибудь обновления, чтобы устранить недостаток?
19.03.2007, 01:46
Ответить | Цитировать
ktotoff
АльтерЛан

Зарегистрирован:
2006-12-19
Сообщений: 330

Полагаю, что никто этим заниматься не будет. Во все развиваемые версии системы встроен FCK, гораздо более удобный (а если поковыряться в коде - просто обалденно удобный и настраиваемый). А неразвиваемые версии системы (например СБ 22) - они на то и не развиваемые улыбка

Кстати, разработчики уже неоднократно говорили, что реликтовые эдитор будет вовсе исключен из следующей версии. Сейчас он присутствует, например, в ветке 2.4, только потому, что скорее всего его не успели выковырять (ну или для совместимости с уже работающими проектами) улыбка

НО! Чтобы вы не очень расстраивались, дам вам направление: код стандартного едитора. Пытливый ум всегда найдёт, где и чего пофиксить.

...жизнь прекрасна, когда правильно подобраны антидепрессанты...
19.03.2007, 13:08
Ответить | Цитировать
h/z

Зарегистрирован:
2007-02-06
Сообщений: 755

эту строчку надо заменить
Код:
var ie6 = navigator.appVersion.indexOf("MSIE 6.")>0 || navigator.appVersion.indexOf("MSIE 5.5")>0;

заменить на
Код:
var ie6 = navigator.appVersion.indexOf("MSIE 7.")>0 || navigator.appVersion.indexOf("MSIE 6.")>0 || navigator.appVersion.indexOf("MSIE 5.5")>0;


htmledit/editor.htm строка 30
htmledit/editor1.htm строка 27
htmledit/functions.js строка 35
htmledit/functions.js строка 64
htmledit/editor.php строка 32
19.03.2007, 19:15
Ответить | Цитировать
Гость
Гость

Спасибо тебе, добрый человек!
21.03.2007, 00:45
Ответить | Цитировать
Гость
Гость

Вот только что досадно: теперь происходят "ошибки сценария" при попытке войти по кнопкам "цвет текста", "шрифт" и т.п. в визуальном редакторе
21.03.2007, 11:32
Ответить | Цитировать
h/z

Зарегистрирован:
2007-02-06
Сообщений: 755

либо обновляйте НетКет до текущей версии,
либо поставьте обратно 6-ой эксплорер ;)
либо замените на другой редактор (но скорее всего в другом редакторе надо будет какую-нибудь дополнительную функцию на JavaScript написать)
17.04.2007, 00:22
Ответить | Цитировать
law
Php-nuke

Зарегистрирован:
2005-11-02
Сообщений: 47

Хм... выполнил рекомендации по редактированию указанных файлов... алерт выскакивать перестал, но и окошко редактирования не появляется.

NetCat Standart + all update + IE7
17.04.2007, 11:41
Ответить | Цитировать
h/z

Зарегистрирован:
2007-02-06
Сообщений: 755

для версии 2,4
Инструменты -> Базовые настройки системы -> Изменить настройки системы -> Редактор -> Тип html-редактора -> FCKeditor
20.04.2007, 15:46
Ответить | Цитировать
law
Php-nuke

Зарегистрирован:
2005-11-02
Сообщений: 47

h/z писал(а):
для версии 2,4
Инструменты -> Базовые настройки системы -> Изменить настройки системы -> Редактор -> Тип html-редактора -> FCKeditor


Гы, разобрался почему не работал FCKeditor - его банерорезка AdMuncher пришибала...
25.04.2007, 19:02
Ответить | Цитировать
ktotoff
АльтерЛан

Зарегистрирован:
2006-12-19
Сообщений: 330

law писал(а):
Гы, разобрался почему не работал FCKeditor - его банерорезка AdMuncher пришибала...


Такая же хрень с IEPro по дефолту улыбка



...жизнь прекрасна, когда правильно подобраны антидепрессанты...
198 196 2007-04-25 19:02:56 10003
Описание проекта