Регистрация
Вход через соцсети
Восстановление пароля

Спасибо разработчикам за 5 версию :)

Новый топик
Страницы: 1  |  2
19.02.2014, 08:39
Ответить | Цитировать
Гость
Гость

Снова встретился тот сайт с 1251. Когда с сайта 1251 экспортируешь компонент в файл, а затем на системе с utf-8 пытаешься его импортировать, то вылезает ошибка о недостаточности данных о шаблонах компонента. Признаюсь, прочитав текст ошибки, я втупил улыбка Можно ли чё-нить нормальное выводить, к примеру сохранять кодировку чуть ниже <version> и проверять при импорте и если несовпадает, то так и написать "Кодировка импортируемого компонента и кодировка сайта несовпадают. Измените кодировку xml-файла компонента". Версии на которых тестил - 5.2 (1251) -> 5.2 (utf-8).
19.02.2014, 10:14
Ответить | Цитировать
Гость
Гость

В Notepad++ файлы с компонентами перекодируешь в utf-8 и импортируешь, тогда ошибки не выдаёт. Там потом дальше вылазят ошибки в шаблонах компонента по типу этой - " Файл /docs/netcat_template/class/119/121/Class.html не найден". То есть 50% шаблонов нормально залетает, а другая часть просто не записывается на диск. Короче проще вручную компонент со всеми шаблонами создать.
198 196 12574
Страницы: 1  |  2
Описание проекта