Регистрация
Вход через соцсети
Восстановление пароля

2 проблемы с демо версией e-commerce

Новый топик
13.02.2007, 10:23
Ответить | Цитировать
Гость
Гость

Скачал демо е-коммерс. Поставил на домашнем сервере, установилось все ок. Но когда заходишь на сайт пишется следующее
Fatal error: Call to undefined function s_browse_level() in z:homenetcat.lwwwnetcatrequireindex.php(232) : eval()'d code on line 27

При установке выбрал какой то из предложенных макетом.

И вторая проблема в том, что в панеле управления ссылки навигации по панеле отображаются нормально, а вот с названием макетов, названием разделов и похожим проблема, они отображаются вопросиками. Если например создаешь новый макет, то его название он пишет нормально, по-русски. Видимо проблема с кодировкой в БД. Помогите, пожалуйста.
13.02.2007, 13:11
Ответить | Цитировать
Кирилл Хряпин

Зарегистрирован:
2006-06-15
Сообщений: 207

Цитата:
когда заходишь на сайт пишется следующее
Fatal error: Call to undefined function s_browse_level() in z:homenetcat.lwwwnetcatrequireindex.php(232) : eval()'d code on line 27

На наших тестовых серверах ничего подобного с демо-версией не наблюдается ни с одним макетом дизайна (только что перепроверил).
Какая версия MySQL, PHP, Zend Optimizer? Какое значение у настройки sql_mode в MySQL (если установлена версия 5.0 или старше)?
Цитата:
И вторая проблема в том, что в панеле управления ссылки навигации по панеле отображаются нормально, а вот с названием макетов, названием разделов и похожим проблема, они отображаются вопросиками

Такая проблема может возникать при использовании MySQL 4.1 и старше, если кодировка по умолчанию - не cp1251.
Попробуйте выполнить SQL-запрос:
Код:
ALTER DATABASE `ИмяБазыДанныхДляNetcat` DEFAULT CHARACTER SET cp1251

после чего необходимо открыть страницу http://netcat.l/install/, удалить и заново установить систему.
13.02.2007, 16:45
Ответить | Цитировать
Гость
Гость

PHP 5.1.6
MySQL 4.1.16
ZendOptimizer 3.0.1 Windows

По второй проблеме ваши рекомендации не помогли. В phpMyAdmin, на сколько я понял, написано, что кодировка по умолчанию cp1251. Тем не менее я выполнил что вы сказали, но не помогло.
14.02.2007, 11:35
Ответить | Цитировать
Гость
Гость

Вот решил поставить старую версию Денвера, с ПХП 4, помню что у меня работал неткат уже на ней когда-то. Параметры основные те же, кроме PHP, теперь он версии 4.4.2. Все работает, обе проблемы решены.

Но все равно, вдруг возникнет такая проблема, когда я на хостинг с пхп 5 поставлю коммерческую версию, как ее решить?? Странно, что у вас таких проблем не возникало никогда при тестировании продукта.
14.02.2007, 19:07
Ответить | Цитировать
Кирилл Хряпин

Зарегистрирован:
2006-06-15
Сообщений: 207

В коммерческой версией таких ошибок, разумеется, не возникает.

Мне остается только развести руками и сослаться на неудачное расположение звезд (файлы закодированы в режиме совместимости с php4, который, по всей видимости, не совместим с данным сочетанием php5+zend optimizer).

Если возникают какие-либо ошибки при работе полнофункциональной версии системы, мы стараемся оперативно решать их в helpdesk'е, по электронной почте или телефону. Без помощи в случае возникновения проблем не останетесь.
198 196 2007-02-14 19:07:20 8061
Описание проекта